The Momentum Update

* indicates required